Write a recursive method that parses a positive binary number as a string into a decimal integer. //Assume the input is always digit only. //If the input is not a binary number, return the same number in the integer format Sample Input1 //A binary input 11 Sample Output1 3 Sample Input2 //Not a binary input 00112 Sample Output2 112 import java.util.*; import java.lang.*;

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question

Write a recursive method that parses a positive binary number as a string into a decimal integer.

//Assume the input is always digit only. //If the input is not a binary number, return the same number in the integer format Sample Input1

//A binary input 11 Sample Output1 3 Sample Input2 //Not a binary input 00112 Sample Output2 112

import java.util.*;
import java.lang.*;
import java.io.*;

class BinaryToDecimal{

// You can add more methods


public static int binaryToDecimal(String binaryString){
//write your code here

}
}
class DriverMain{
public static void main(String args[]){
Scanner input = new Scanner(System.in);
System.out.print(BinaryToDecimal.binaryToDecimal(input.nextLine()));
}
}

Expert Solution
trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 2 steps

Blurred answer
Knowledge Booster
Time complexity
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education