Write a C program to implement the multiplication and division by 2 using the shift operators.                Multiplication input: Sample input: x=1,N=5  Sample output :  32  [Since 000001 will be 100000 after 5 left shifts] Division input: Sample input: x = 32, N=2 Sample output : 8  [Since 100000 will be 001000 after 2 right shifts]

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Topic Video
Question
  1. Write a C program to implement the multiplication and division by 2 using the shift operators.               

Multiplication input:

Sample input: x=1,N=5 

Sample output :  32  [Since 000001 will be 100000 after 5 left shifts]

Division input:

Sample input: x = 32, N=2

Sample output : 8  [Since 100000 will be 001000 after 2 right shifts]

You can use scanf to read x and N.

Expert Solution
Step 1: C Code

#include<stdio.h> 
// Function for multiplication 
int multiply(int n, int m) 

 int ans = 0;
  if (m>-1)    
   ans += n <<m;
 return ans; 

// Function for division 
int divide(int n, int m) 

 int ans = 0;
  if (m>-1)    
   ans += n>>m;
 return ans; 
}
// Driver code 
int main() 

    int x,N;
    printf("Enter x and N : ");
    scanf("%d %d",&x,&N);
 printf("Multiply Output : %d",multiply(x, N));
 printf("\nDivision Output : %d",divide(x, N));
 return 0; 

trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 2 steps with 1 images

Blurred answer
Knowledge Booster
Instruction Format
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education